Issue: Visma Lønn, random errors when showing “print” previews

This is just a quick post for an issue with Visma’s “Visma Lønn” application, that it may be nice to be aware of.
In Norway there are a few companies using “Visma Lønn” for payslips etc.
Some users may experience issues when doing some of the processes in the application, especially reports that involve the “Crystal reports” component.
When generating the reports, and when expecting the preview to show inside the application window, the user may get some “random” error messages.

Like:

  • Overflow error
  • Error 429 – active X related
  • Run-Time errors – like “6”
  • Various VLAXControls errors
  • DLL errors

Visma has an article about print issues (“print” is involved here) that can be found here:

https://community.visma.com/t5/Brukertips-i-Visma-Lonn/Feilmelding-ved-utskrifter/ta-p/26014

Suggested things to try there are:

  • Start Visma Lønn on the server with an admin account, run a print job, see if problem goes away.
  • Re-register the VLAXControls.ocx and mscomct2.osx files with the regsvr32 command.
    Files standar location here: Program files/Visma/Lonn/

If these things don’t help, there is I chance you have the same issue as stated in the beginning, with random errors popping up.

Now, in 2021 and going forward, we have users getting more advanced devices and setups on the client side.
And one of the things we se more and more of, is monitors getting larger resolutions, 4k displays becoming more and more common.

And, if you are running into the issues above, there is a good chance this is the cause of the problem you are seeing.

The reports and previews generated by Visma Lønn, just seem to crash if the client’s resolution is too large.

So, the fix, for now, is as easy as running the Visma Lønn application in a smaller size, to work around the issues until (if), the issue gets resolved as a whole.

Running a 4K wide display, anchor the application to one of the sides of the monitor to make it take 50% of the screen. (Just drag the application all the way to one of the sides until you get a gray box indicating where it will be anchored.
Others, just make it smaller and try again, it will work if the window is not too big.

The problem shows itself both on Citrix server, RDS, and fat clients (locally installed)

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.